System Requirements - 5.1 & Prior Releases

Modified on Thu, 23 May 2024 at 12:32 AM

Upgrades


Before we can proceed with the update, please ensure that all the requirements in the attached document for the relevant version are addressed. Confirmation must be provided by your IT during the update process. Please contact us at support@practiceevolve.com.au if you require further assistance or clarification.


5.1 Release


Microsoft have ceased extended support for SQL Server 2008 R2 and Windows Server 2008 R2. As such, we no longer support this version in its Express and Standard editions. This will cause certain reports to not run correctly.


5.0 Release


Updated document to include Web portal requirements.


Updated document to reflect support ceasing for Windows 7, Microsoft Server 2008 R2 and Microsoft SQL Server 2008 R2


Updated recommended workstation CPU requirements


4.4 Release


SBS 2011 not Supported due to SBS 2011 not having sufficient .Net Framework. 


4.3 Release


Included requirements for the Cloud Portal.


4.1 Release


Microsoft .Net Framework 4.6.1 on both Server and Client environment is now a minimum requirement. Clarified Office 365 compatibility only for the "Desktop" version. 


4.0 Release


Updated specifications to include Windows 2016 Server, and SQL Server 2017 as recommended options.


3.9 Release


The Microsoft Distributed Transaction Coordinator (MS DTC) Service needs to be running on both the application server and SQL server. This is required to ensure cheque requisition and other accounting operations can run successfully.


From version 3.9 onwards, various analytical functions have been made available in the software. They will require the "Microsoft SQL Server 2014 Analysis Services OLEDB Provider, 64-bit (ENU\x64\SQL_AS_OLEDB.msi)" to be installed. This should be installed on both the application server and client machines. This is not dependent on the version of SQL installed, and can be downloaded here (https://www.microsoft.com/en-au/download/details.aspx?id=42295)


3.8 Release & Historic References


The next version of Practice Evolve contains a number of features that relies on some of the newer technologies offered by Microsoft.  In order for you to take advantage of these new features, you have to ensure your server and workstations are installed with these Microsoft updates. Thankfully, these new technologies are freely available for all versions of Windows released after Windows XP and Server 2003.


Some of the new features in Practice Evolve require the .NET Framework 4.5.  Because we deliver the software as a single package, if you are still using Windows XP and Windows Server 2003, we will unfortunately not be able to provide the new Practice Evolve release to you.  It is also worth noting that Microsoft have stopped supporting Windows XP on April 8, 2014, and have also stopped supporting Windows Server 2003 on July 14, 2015.  


We have other requirement such as Powershell 4.0, that can only be installed with the Management framework 4.0 that comes with Windows 2008 R2 servers or newer. There are some system such as Small Business Servers that do not support Powershell 4.0, and unfortunately we will not be able to support these.


 


 


Keywords: server client minimum specification requirement

Attachments (7)

Was this article helpful?

That’s Great!

Thank you for your feedback

Sorry! We couldn't be helpful

Thank you for your feedback

Let us know how can we improve this article!

Select atleast one of the reasons
CAPTCHA verification is required.

Feedback sent

We appreciate your effort and will try to fix the article